Über diese Hilfe

Diese Hilfe bezieht sich auf Version 0.3 beta vom August 2005.

Autor:
Philipp Crocoll
philipp@codecolony.de
www.codecolony.de/GetAGallery/


Systemvoraussetzungen

Get a Gallery ist ein sehr genügsames Programm. Es läuft auf jedem Windows-System ab Windows 95. Je schneller der PC, desto schneller können die Galerien erzeugt werden. Dies macht sich aber erst bei sehr großen Galerien bemerkbar.


Download und Installation

Um Get a Gallery zu installieren, laden Sie sich bitte die aktuelle Version von http://www.codecolony.de/GetAGallery herunter.
Sie erhalten dort eine EXE-Datei, namens GetAGallery_Setup_[Ver].exe, wobei [Ver] für die Versionsbezeichnung steht.
Diese EXE-Datei starten Sie bitte durch einen Doppelklick. Das nun startende Programm führt Sie durch die Installation.


Was kann ich mit Get a Gallery machen?

Get a Gallery ist ein Programm zum Erzeugen von Galerien für's Web. Sie sagen dem Programm welche Bilder Sie in einer Galerie zusammenfassen möchten und das Programm erzeugt Ihnen sämtliche benötigten Dateien - die verkleinerten Bilder ebenso wie HTML- und CSS-Dateien.
Dabei sind Ihrer Kreativität wenig Grenzen gesetzt: Wenn Sie möchten, können Sie eigene "Skins" erzeugen. Diese definieren viel mehr als nur Farben oder Schriftarten. Sie können damit den gesamten Aufbau Ihrer Galerie definieren. Dies lässt sich an den bisher verfügbaren Skins schon erkennen, obwohl noch viele Skins folgen sollen.
So ist neben einigen "normalen" Skins z.B. auch ein "Skin" dabei, der einfach nur Bilder verkleinert und gar keine HTML-Dateien erzeugt. Es können übrigens genauso gut auch PHP-Seiten erzeugt werden, mit denen ein Einbinden der Galerie in eine bestehende, dynamische Homepage noch einfacher ist. Ebenso wäre eine Ausgabe in TXT, CSV oder XML-Formate möglich.
Get a Gallery soll in künftigen Versionen ein ganz spezielles Feature erhalten: Dann sollen nämlich zu jedem Bild aus einer Datenbank zusätzliche Informationen geholt und in der Galerie angezeigt werden können.


Das Startfenster

Wenn Sie das Programm gestartet haben, begegnet Ihnen ein Fenster in folgender Form:

Es besteht aus folgenden Elementen:
Auf der linken Seite sehen Sie in der oberen Hälfte die Verzeichnisstruktur Ihres PCs. Wenn Sie ein Verzeichnis ausgewählt haben, in dem sich Bilder im JPG-Format befinden, sehen Sie diese in der unteren Hälfte aufgelistet:


Dateien auswählen

Im ersten Schritt müssen Sie dem Programm mitteilen, welche Bilder Sie in Ihre Galerie einfügen möchten. Dazu wählen Sie die gewünschten Bilder aus der Dateiliste links unten im Fenster aus. Mit den Tasten "Shift" und "Strg" können Sie auch mehrer Bilder auf einmal wählen. Anschließend können Sie diese per "Drag-and-Drop" oder den Button "Hinzufügen >>" in die Liste auf der rechten Seite bringen. Dies ist die Liste der Dateien, die später in der Galerie zu sehen sein werden.
Bitte beachten Sie, dass die Reihenfolge, in der Sie die Bilder in die Liste auf der rechten Seite einfügen der Reihenfolge entspricht, in der die Bilder in der Galerie erscheinen werden.
Diesen Vorgang können Sie natürlich für Bilder aus verschiedenen Verzeichnissen wiederholen.
Sollten Sie ein Bild doch nicht in Ihrer Galerie wünschen, können Sie es in der Liste rechts auswählen und die "Entf"-Taste drücken. So verschwindet es aus der Liste.


Zusatzinformationen eingeben

Vielleicht möchten Sie in Ihrer Web-Galerie nicht nur Bilder präsentieren, sondern diese auch beschreiben? Dann können Sie die Bilder mit Zusatzinformationen versehen.
Wählen Sie hierzu ein Bild aus der Liste auf der rechten Seite aus:

Es erscheint eine Bildvorschau und eine kleiner Liste daneben. Ganz rechts finden Sie einen Button "neue Eigenschaft". Mit diesem können Sie den Namen einer neuen Bildeigenschaft definieren. Welche Bildeigenschaften in einer Galerie angezeigt werden, ist abhängig vom verwendeten Skin. Die mitgelieferten Skins zeigen alle die Eigenschaft "description" an. Andere Skins können andere Eigenschaften anzeigen. Welche dies sind, können Sie dort erfahren, wo Sie den Skin heruntergeladen haben.
Wenn Sie die Eigenschaft hinzugefügt haben, können Sie für jedes Bild einen Wert für diese Eigenschaft eingeben:


Dateilisten speichern und laden

Nachdem Sie nun eine Dateiliste erstellt haben, können Sie diese mit einem Klick auf das Symbol [image] speichern. Auch die eingegeben Eigenschaften werden dabei gesichert.
Eine so gespeicherte Liste können Sie mit einem Klick auf [image] später wieder laden.


Eine Galerie erzeugen

Wenn Sie alle gewünschten Dateien in die Dateiliste eingefügt haben und alle Informationen zu den Bildern eingegeben haben, können Sie zum nächsten Schritt übergehen: Dem Erzeugen der Galerie. Dafür klicken Sie auf den Button "Galerie erzeugen".
Sie sehen ein neues Fenster:


Skin auswählen

Am meisten wird das Aussehen und auch die Struktur Ihrer Galerie von der Wahl des Skins beeinflusst. Ganz oben im Fenster können Sie aus einer Liste von Skins auswählen. Wenn Sie die Auswahl ändern, ändern sich einige Elemente des Fensters. So sehen Sie z.B. immer ein kleines Vorschau-Bild, das Ihnen eine Vorstellung davon verschaffen kann, wie der gewählte Skin ungefähr aussieht. Eine exakte Vorschau ist nicht möglich, weil Sie selbst noch einige Parameter anpassen können.
Bei Klick auf das Vorschaubilder öffnet sich ein größeres Fenster, in dem Sie das Bild besser betrachten können.


Ausgabepfad wählen

Die nächste Einstellung, die Sie vornehmen sollten, ist den Ausgabepfad für Ihre Galerie zu wählen. Get a Gallery schlägt den im Hauptfenster zuletzt gewählten Pfad vor, allerdings mit dem Unterverzeichnis "gallery". Wenn Sie diesen Pfad ändern möchten, können Sie den gewünschten Pfad direkt in das dafür vorgesehene Feld eintippen oder mit Hilfe des "Durchsuchen"-Buttons ändern. Ein noch nicht bestehendes Verzeichnis wird inklusive aller Unterverzeichnisse erzeugt.
Wenn das Verzeichnis schon existiert, haben Sie die Möglichkeit, es von Get a Gallery vor der Galerieerzeugung leeren zu lassen. Wenn Sie dies nicht tun, kann es sein, dass Dateien, die Get a Gallery erzeugen möchte, schon existieren. Dann werden diese nicht überschrieben, sondern die neuen Dateien werden mit einem Zählindex versehen. So wird z.B. aus "index.html" eine "index3.html", wenn index.html und index2.html schon existieren.
Wenn Sie den Haken bei "Verzeichnis vor Galerieerzeugung leeren" setzen, werden alle Dateien und Unterverzeichnisse des Ausgabepfades in den Papierkorb verschoben, sind also wiederherstellbar.


Galerie anpassen

Wenn Sie sich für einen Skin entschieden haben, können Sie diesen in der Regel noch an Ihre Wünsche anpassen. Dies kann aber je nach Skin auch sehr eingeschränkt oder gar nicht möglich sein.
Gewöhnlich sind Werte wie ein Galeriename und verschiedene Farben wählbar. Wenn der Skin eine Übersichtsseite enthält, wird er Ihnen oft auch anbieten, die Anzahl an Thumbnail-Bildern pro Zeile einzustellen.
Außer den Werten für die HTML-Dateien der Galerie können Sie außerdem definieren, wie die Bilder von Get a Gallery verarbeitet werden sollen.("Verarbeitung" meint in der aktuellen Version nur das Verkleinern. Später könnten hier auch wirkliche Bearbeitungsfunktionen hinzukommen).
Auch hier ist wieder vom Skin abhängig, wie viele verschiedene neue Bilder erzeugt werden. In einer typischen Galerie werden sog. Thumbnails, also kleine Vorschaubilder erzeugt und dann noch ein mittelgroßes Bild, welches sich gut auf dem Bildschirm betrachten lässt, aber nicht die Originalgröße besitzt. Je nach Skin können aber beliebig viele neue Bilder erzeugt werden. Falls der Skin anbietet, das Originalbild (also in voller Größe) anzuzeigen, sollte der Haken bei "Originale der Bilddateien kopieren" gesetzt sein. Dann werden die Originaldateien ins Galerieverzeichnis kopiert.

Alle Werte, die Get a Gallery standardmäßig anzeigt, sind übrigens vom Skin als Vorschläge definiert. Je nach der Flexibilität des Skins, kann es zu unschönen Ergebnissen führen, Werte zu stark zu modifizieren.


Hinweise zu den mitgelieferten Skins

In der aktuellen Version sind noch nicht sehr viele Skins enthalten. Bisher finden Sie
  • Arctic und CoolGal: zwei einfache Galerien mit Übersichts- und Einzelbildseiten.
  • FastNav: eine Framebasierte Galerie, die in einem oben angebrachten Frame Übersichtsbilder anzeigt
  • ImageResize: Erzeugt keine "echte" Galerie, sondern verkleinert nur die Bilder. Kann für viele Aufgaben sinnvoll sein.
  • phpGal: Dieser Skin erzeugt nicht für jedes Bild eine eigene HTML-Seite, sondern nutzt PHP, um die Bilder anzuzeigen. (Das Verkleinern der Bilder wird aber von Get a Gallery übernommen).
    Um diesen Skin nutzen zu können benötigen Sie einen PHP-fähigen Webserver.


Skins herunterladen

Wenn Sie im Internet einen neuen Skin für Get a Gallery finden, können Sie diesen in der Regel als gepackte Datei (z.B. ZIP oder RAR) herunterladen. Um den Skin standardmäßig in der Auswahlliste von Get a Gallery zu haben, entpacken Sie diesen in das Verzeichnis "Skins" im Programmordner von Get a Gallery. Wenn Sie den Skin an anderer Stelle entpacken, können Sie ihn mit dem Button "weiteren Skin laden" benutzen.


Eigene Skins erzeugen

Das bisher wichtigste Merkmal von Get a Gallery ist die Möglichkeit, sehr flexible Skins selbst erzeugen zu können. Um dies tun zu können, ist es sehr sinnvoll schon etwas Erfahrung mit HTML und evtl. auch CSS gesammelt zu haben.


Allgemeines

Im folgenden wird von "Datensätzen" gesprochen. Auch wenn im Moment noch keine Datenbankanbindung möglich ist, so werden die Daten eines jeden Bildes als ein Datensatz bezeichnet. Darin sind enthalten: Der Originalpfad und -dateiname, Bildgröße, JPG-Metadaten und die vom Benutzer zusätzlich eingegebenen Informationen.
Wenn Sie zum ersten Mal einen Skin erzeugen, ist es sehr hilfreich, die Dateien der mitgelieferten Skins genau anzuschauen. Evtl. kann ein neuer Skin auch auf Grundlage eines bestehenden Skins erzeugt werden. Dazu ist es sinnvoll das Skinverzeichnis zu kopieren umzubenennen, die Dateien darin evtl. umzubenennen und deren Inhalt anzupassen.


Grobe Funktionsweise der Galerieerzeugung

Get a Gallery geht beim Erzeugen einer Galerie folgendermaßen vor:
  • Zuerst werden alle benötigten Bilder erzeugt
  • Im nächsten Schritt wird ermittelt, welche Ausgabe-Dateien (meist HTML) erzeugt werden und welche Datensätze in welcher Datei auftauchen. So sind in einer Übersichtsseite meist mehrere Datensätze zu sehen, während Einzelbildseiten nur ein oder zwei Bilder enthalten.
  • Der dritte Schritt erstellt dann den Inhalt der Ausgabe-Dateien. Der vorige Schritt ist hierfür Voraussetzung, weil nur so an dieser Stelle schon die Links auf Folgeseiten gesetzt werden können


Für einen Skin benötigte Dateien

Ein Skin besteht aus einer Sammlung an Dateien, die in einem Verzeichnis zusammengefasst werden. Dieses Verzeichnis kann das Unterverzeichnis "files" enthalten. Dieses Verzeichnis wird direkt und komplett ins Galerieverzeichnis kopiert. Hier können Hintergrundbilder abgelegt werden. CSS-Dateien nur dann, wenn der Benutzer später keine Einstellmöglichkeiten darin haben soll.
Im Skin-Verzeichnis werden folgende Dateien benötigt:
  • [Skinname].gsk: Ist eine Datei im INI-Format, die allgemeine Informationen zum Skin enthält. Nähere Beschreibung siehe Die GSK Datei
  • Eine CSV-Datei, die beschreibt, welche neuen Bilder erzeugt werden sollen (z.B. Thumbnails und mittelgroße Bilder). Nähere Beschreibung siehe Die CSV-Datei für die "ImageModifications"
  • Eine CSV-Datei, die die sogenannten Patterns beschreibt. Ein Pattern ist eine Datei, die als Vorlage für alle Seiten eines Typs dient (z.B. gibt es in CoolGal ein Pattern für die Einzelseiten und eine Patterndatei für die Übersichtsseiten). Nähere Beschreibung siehe Die CSV-Datei für die HTML-Patterns
  • Eine CSV-Datei, die beschreibt, welche Werte der Benutzer im "Galerie erzeugen"-Dialog selbst einstellen kann. Nähere Beschreibung siehe Die CSV-Datei für die "Required Variables
  • Alle Pattern-Dateien im Get a Gallery eigenen "hpt" (HTML-Pattern) Format. Nähere Beschreibung siehe Patterndateien erstellen


Die GSK-Datei

Die GSK-Datei (GSK="gallery skin") enthält allgemeine Informationen zum Skin. Sie ist eine Datei im Windows-INI-Format. Sie besteht aus einer Section namens General. Diese Section wird durch die Zeile
[General]
eingeleitet. In dieser Section sind folgende Werte zulässig bzw. nötig:
  • SkinName: Der Wert, der als Skinname in der Liste des "Galerie erzeugen"-Dialogs angezeigt wird
  • Preview (optional): Der Dateiname einer Bilddatei, die als Vorschau für den Skin benutzt werden kann. Diese Datei muss im Skinverzeichnis oder einem Unterverzeichnis liegen.
  • Startpage (optional): Name des Patterns, das als Startseite aufgerufen werden kann. Dies ist z.B. "OverviewPage", wenn das Pattern für die Übersichtsseite einer Galerie "OverviewPage" heißt. Sollten mehrere solcher Seiten erzeugt werden, weil nicht alle Bilder auf der Seite dargestellt werden, so wird die erste erzeugte Datei benutzt. (Dieser Wert wird nach der Galerieerstellung benutzt, wenn auf "Galerie anzeigen" geklickt wird).
  • CopyOriginalImages: Hat den Wert "Yes" oder "No". Gibt die Standardeinstellung für den Haken bei "Originale der Bilddateien kopieren" an.
  • Author (optional): Name des Autors. Wird in "Galerie erzeugen" angezeigt.
  • AuthorEMail (optional): E-Mail-Adresse des Autors. Wird ebenfalls in "Galerie erzeugen" angezeigt.
Als zweite Section folgt "CSV". Hierin werden die Dateinamen der drei benötigten CSV-Dateien angegeben. Dies geschieht über die Schlüssel ImageModification, HTMLPatterns und RequiredVars.


Die CSV-Datei für die "ImageModifications"

Diese CSV-Datei definiert, welche verschiedenen "Bildtypen" erzeugt werden sollen. Dies sind z.B. Thumbnails oder mittelgroße Bilder.
Dies wird in einer Art Tabelle im CSV-Format getan. Die Spalten müssen
  • Name
  • Description
  • DefaultMaxWidth
  • DefaultMaxHeight und
  • NewName
heißen.
Daher lautet die erste Zeile dieser Datei immer
Name;Description;DefaultMaxWidth;DefaultMaxHeight;NewName

Die Spalte Name gibt den Namen dieses Bildtyps an, z.B. "Thumbnail". Der Name wird in den HTML-Patterns wieder benötigt. Leerzeichen sind hier nicht erlaubt.
Die Spalte Description beschreibt, wofür diese Bilder benutzt werden sollen. Dies wird dem Benutzer später angezeigt. DefaultMaxWidth und DefaultMaxHeight sind die Standardwerte für die maximalen Maße. Beachten Sie, dass der Benutzer diese noch ändern könnte.
NewName gibt an, welchen neuen Dateinamen die Bilder diesen Typs erhalten sollen. Wenn sie z.B. "thumb" eingeben, werden die Bilder thumb.jpg, thumb2.jpg, thumb3.jpg heißen.
Sie können aber auch den Platzhalter %old% benutzen, so würde thumb_%old% dazu führen, dass aus "img_1234.jpg" das Bild thumb_img_1234.jpg gemacht wird. Beachten Sie, dass in dieser Spalte niemals eine Endung eingegeben werden sollte. Diese wird immer automatisch angefügt. Wenn Sie die Spalte leerlassen, wird übrigens der Original-Dateiname eingesetzt.


Die CSV-Datei für die HTML-Patterns

Der Name HTML-Patterns ist leicht irreführend. Es können natürlich auch Dateien, die nicht im HTML-Format sind, ausgegeben werden.
Ähnlich wie bei den Bilddateien können beliebig viele Text-Dateien erzeugt werden. Hierbei wird aber nicht für jeden Typ einer Textdatei zwangsläufig eine Ausgabedatei pro Datensatz erstellt. Oft werden auch mehrere Datensätze in einer Datei angezeigt (z.B. auf Übersichtsseiten).
Die CSV-Datei für die Ausgabedateien enthält folgende Spalten:
  • Filename
  • Name
  • NewFilename
Filename gibt den Dateinamen der Pattern-Datei im hpt-Format an. Name wird in den Pattern-Dateien benötigt, hier ist z.B. "OverviewPage" ein sinnvoller Name. Leerzeichnen sind nicht erlaubt. NewFilename gibt an, wie die erzeugten Dateien heißen sollen. Wird der Wert leer gelassen, wird der Dateiname des Bildes, aber mit der Endung .html verwendet. Wenn Sie einen Dateinamen angeben, muss dieser - anders als bei den Bildern - eine Endung haben.


Die CSV-Datei für die "Required Variables"

In der dritten CSV-Datei wird angegeben, welche Werte der Benutzer im "Galerie erzeugen"-Dialog einstellen kann.
Sie enthält die Spalten
  • VariableName
  • Description
  • Type und
  • DefaultValue
Die Spalte "VariableName" gibt den Namen der Variablen an, der auch in den Patterns benutzt werden kann. Die "Description" wird dem Benutzer im Dialog angezeigt, damit dieser weiß, was der einzustellende Wert bewirkt. Die Spalte "Type" kann folgende Werte annehmen:
  • TEXT: Der Benutzer soll einen Text eingeben, z.B. einen Galerienamen
  • NUMBER: Der Benutzer soll eine Zahl eingeben, z.B. eine Tabellenbreite oder die Anzahl von Thumbnails auf einer Seite
  • COLOR: Der Benutzer soll eine Farbe auswählen. Diese kann im HTML-Farbformat in eine Ausgabedatei eingefügt werden.
Die Spalte DefaultValue enthält den Standardwert der Variablen.


Patterndateien erstellen

Der wichtigste und gleichzeitig komplexeste Teil beim Erzeugen von Skins ist es, die Patterndateien zu erstellen. Auf alle Fälle ist es immer sinnvoll, sich das gewünschte Resultat zuerst als gewöhnliche HTML-Datei (oder einem anderen "Zielformat") zu erstellen. Erst dann sollte daraus eine HPT-Datei gemacht werden. Der Get a Gallery Parser ist dafür zuständig, die HPT-Dateien in die gewünschten Ausgabedateien umzuwandeln. Dabei wird "gewöhnlicher" Dateiinhalt einfach eins zu eins in die neue Datei kopiert. Folgende Dinge aber werden vom Parser speziell behandelt:
  • Platzhalter:
    Ein Platzhalter hat die Form %Platzhaltername%. Dieser Ausdruck wird immer durch einen Wert ersetzt, der aus einer von mehreren Quellen stammen kann. So gibt es einige fest definierte Platzhalternamen, andere entsprechen den vom Benutzer eingegeben Bildeigenschaften und andere sind vom Skin definiert (Required Variables). Auch die Metadaten aus JPG-Dateien können so in einer Datei ausgegeben werden.
    Sollte der Platzhaltername dem Parser nicht bekannt sein, so wird der Ausdruck dennoch nicht in die Ausgabe kopiert sondern fällt weg.
    s. Liste der Platzhalter
  • Bedingungen:
    Stellen Sie sich vor, Sie möchten eine Vorlage für eine Einzelbildseite definieren. Auf dieser Einzelbildseite sollen die Links "Zum vorigen Bild" und "Zum nächsten Bild" erscheinen. Was aber passiert auf der ersten und auf der letzten Seite? Dort gibt es entweder kein voriges oder kein nächstes Bild!
    Mit Hilfe einer "Bedingung" können Sie dem Parser sagen, dass der Link nur erscheinen soll, wenn eine Bedingung erfüllt ist oder eben nicht erfüllt ist.
    Eine Bedingung wird immer mit "[GAG] Condition" oder "<!--[GAG] Condition" eingeleitet. Dies muss am Anfang einer Zeile stehen!
    Darauf folgt, mit Leerzeichen getrennt und in runden Klammern gesetzt, die eigentliche Bedingung.
    Eine Bedingung besteht entweder aus einem Ausdruck oder aus zwei Komparanten, die mit einem "="-Zeichen getrennt sind.
    Ein solcher Ausdruck oder ein Komparant kann folgende Schlüsselwörter enthalten:
    • ISFIRSTIMAGE: Ist "wahr", wenn das Bild, das im Moment verarbeitet wird, das erste Bild der Liste ist
    • ISLASTIMAGE: Ist "wahr", wenn das Bild, das im Moment verarbeitet wird, das letzte Bild der Liste ist
    • IMGINDEXISEVEN: Ist "wahr", wenn das Bild einen an einer geraden Stelle in der Liste steht. Also beim 2., 4., 6. Bild usw.
    • TRUE: Ist immer "wahr"
    • FALSE: Ist nie "wahr"
    • DoesExist([Platzhaltername]): Dabei steht [Platzhaltername] für einen beliebigen Platzhalternamen. So kann z.B. mit "DoesExist(description)" geprüft werden, ob ein Platzhalter %description% existiert oder nicht.
    Eine Bedingung wird immer mit der Zeile "" oder [GAG] End Condition abgeschlossen. Einige Beispiele für Bedingungen sollten dies erläutern: Das Schachteln von Bedingungen ist in der aktuellen Version noch nicht erlaubt.
  • Abschnitte:
    Einige Zeilen wiederholen sich in einer HTML-Datei manchmal mehrfach, zumindest sind diese Wiederholungen von der gleichen Struktur. Besonders, wenn Sie z.B. eine Tabelle als Übersichtsseite einer Galerie erstellen. Die Zeilen, um eine Tabellenzelle zu öffnen, ein Bild anzuzeigen und die Tabellenzelle zu schließen, sind doch immer wiederkehrend, allerdings wird jedes mal ein anderes Bild angezeigt.
    In einer Patterndatei können Sie einen einzigen "Abschnitt" oder eine "Section" definieren und dem Parser mitteilen, für wie viele Bilder dieser wiederholt werden soll. Außerdem lassen sich diese Abschnitte ineinander schachteln. Ein typisches Beispiel ist das Erzeugen einer Tabelle, dies sieht ungefähr so aus:
    <!--[GAG] NewSection (Name:Zeile;NumRepeat:2)-->
  <tr  height=170>
<!--[GAG] NewSection (Name:Bild;NumRepeat:3)-->
      <td valign="middle" align="center" width="170">
      [Inhalt der Zelle, basierend auf bildbezogenen Platzhaltern]
      </td>
<!--[GAG] EndSection (Name:Bild)-->
  </tr>
<!--[GAG] EndSection (Name:Zeile)-->
    Hier wird eine Section mit dem Namen Bild begonnen. Durch NumRepeat:2 wird angegeben, dass drei solcher Sections hintereinander ausgegeben werden sollen. Innerhalb der Section wird eine Tabellenzeile mit tr geöffnet. Dann wird noch einmal eine Section begonnen. Diese hat den Namen Bild. Darin wird eine Tabellenzelle geöffnet, dann kann HTML-Text kommen und die Zelle wird wieder geschlossen. Diese Section soll dreimal wiederholt werden. Danach wird mit einem /tr die Tabellenzeile beendet.
    So kann also eine Tabelle mit zwei Zeilen und drei Spalten erstellt werden. Raffinierter ist es, NumRepeat:%AnzZeilen% zu schreiben und die Variable %AnzZeilen% in der Datei RequiredVars.csv einzutragen. Dann kann der Benutzer selbst wählen, wie viele Zeilen er möchte.
    Für den Parser sind die Sections sehr wichtig. Er hält jede Section, die keine Untersections besitzt für eine "Bild-Section", das heißt, er bearbeitet nach einer solchen Section den nächsten Datensatz. Wenn in einer Datei keine Section definiert ist, wird die gesamte Datei für eine Section gehalten.
    Wenn der Parser am Ende der Patterndatei angelangt ist, beginnt er eine neue Ausgabe-Datei und beginnt, ausgehend vom aktuellen Datensatz wieder, die Patterndatei von oben nach unten abzuarbeiten.
    Wenn Sie eine Section so oft wiederholen möchten, bis alle Datensätze abgearbeitet wurden, müssen Sie als Anzahl der Wiederholungen 0 angeben, also NumRepeat:0 schreiben.
  • Die Zeile [GAG] ResetCounter setzt den Datensatz-Zähler im Parser auf 0 zurück. Dadurch kann innerhalb einer Seite mehrmals auf alle Bilder zugegriffen werden. (s. z.B. phpGal)


Liste der Platzhalter

Folgende Platzhalter können Sie benutzen:
  • Benutzerdefinierte Platzhalter: Wurde z.B. die Bildeigenschaft "description" eingegeben, können Sie darauf mit %description% zugreifen
  • Die RequiredVars des Skins werden als Platzhalter zur Verfügung gestellt: Der als "VariableName" angegebene kann (wieder in %-Zeichen) benutzt werden
  • First_[PatternName] und Last_[PatternName]:
    Für jedes HTML-Pattern existiert ein Platzhalter, der den Dateinamen der ersten bzw. letzten Datei enthält, die aus diesem Pattern erzeugt wurde. Sinnvoll z.B. wenn ein Link auf die erste Übersichtsseite gesetzt werden soll.
  • Next_[PatternName] und Previous_[PatternName]:
    Für jedes HTML-Pattern existiert ein Platzhalter, der den nächsten bzw. vorigen Dateinamen der Datei enthält, die aus diesem Pattern erzeugt wurde. Sinnvoll z.B. wenn ein Link auf die nächste Übersichtsseite gesetzt werden soll.
  • NextRecord_[PatternName] und PreviousRecord_[PatternName]:
    Wie Next_[PatternName] bzw. Previous_[PatternName], enthält nicht die nächste bzw. vorige erzeugte Datei sondern die zum nächsten bzw. vorigen Datensatz gehörende Datei.
  • [PatternName]: Enthält die zum aktuellen Datensatz aus dem entsprechenden Pattern erzeugte Datei
  • FName: Dateiname des Bildes des aktuellen Datensatzes (inkl. Pfad)
  • FName_no_path: Dateiname des Bildes des aktuellen Datensatzes (ohne Pfad)
  • Num_Records: Enthält die Anzahl der Datensätze in der Galerie
  • Img_index: Index des aktuellen Datensatzes (beginnend bei 0)
  • JPGMETA:[Metaname]: Aus jeder JPG-Datei werden alle verfügbaren Meta-Daten ausgelesen. Wenn z.B. das "EquipModel" in der JPG-Datei steht, ist der Platzhalter JPGMETA:EquipModel mit dem entsprechenden Wert aus der Datei gefüllt.


Variable CSS-Dateien erstellen

Wenn Sie eine CSS-Datei für Ihren Skin benutzen, möchten Sie vielleicht auch einige Werte in dieser variabel, also vom Benutzer wählbar, halten. Daher können Sie eine solche Datei nicht ins "files"-Verzeichnis kopieren. Sonst würde die Datei einfach nur kopiert. Stattdessen muss sie aber vom Parser bearbeitet werden, um Platzhalter zu ersetzen.
Nun möchten Sie aber in einer solchen Datei eigentlich keine Bildinformationen einfügen. Wenn Sie nun die Datei in die HTMLPattern-CSV-Datei eintragen würden, würde die CSS-Datei für jeden Datensatz einmal ausgegeben. Stattdessen können Sie an einer beliebigen Stelle in der CSS-Datei die Zeilen:
[GAG] NewSection (Name:Dummy;NumRepeat:0)
[GAG] EndSection (Name:Dummy)
einfügen. Dann wird die Datei nur ein einziges Mal ausgegeben.